noteから引っ越してきた記事
設定
[Rule]
- gi0/0: site
- gi0/1: internet
[Main Site]
R8
en
conf t
hostname iosv-8
line console 0
logg syn
privi l 15
exit
!
int lo1
ip add 18.1.1.8 255.255.255.255
!
int gi0/0
ip add 187.1.1.8 255.255.255.0
no shut
exit
!
router eigrp 100
net 187.1.1.8 0.0.0.0
net 18.1.1.8 0.0.0.0
end
R1
en
conf t
hostname iosv-1
line console 0
logg syn
privi l 15
exit
!
int gi0/0
ip add 187.1.1.1 255.255.255.0
no shut
!
int gi0/1
ip add 15.1.1.1 255.255.255.0
no shut
!
int tunnel100
ip add 100.1.1.1 255.255.255.0
tunnel mode gre multi
tunnel source 15.1.1.1
ip nhrp network-id 100
ip nhrp map multi dynamic
ip nhrp redirect
ip summary-add eigrp 100 0.0.0.0 0.0.0.0
exit
!
router eigrp 100
net 187.1.1.1 0.0.0.0
net 15.1.1.1 0.0.0.0
net 100.1.1.1 0.0.0.0
end
R7
en
conf t
hostname iosv-7
line console 0
logg syn
privi l 15
exit
!
int gi0/0
ip add 187.1.1.7 255.255.255.0
ip summary-add eigrp 100 0.0.0.0 0.0.0.0
no shut
!
int gi0/1
ip add 57.1.1.7 255.255.255.0
no shut
!
int tunnel100
ip add 100.1.1.7 255.255.255.0
tunnel mode gre multi
tunnel source 57.1.1.7
ip nhrp network-id 100
ip nhrp map multi dynamic
ip nhrp redirect
ip summary-add eigrp 100 0.0.0.0 0.0.0.0
exit
!
router eigrp 100
net 187.1.1.7 0.0.0.0
net 57.1.1.7 0.0.0.0
net 100.1.1.7 0.0.0.0
offset-list 0 out 500 tunnel100
end
[ISP]
R5
en
conf t
hostname iosv-5
line console 0
logg syn
privi l 15
exit
!
int gi0/0
ip add 15.1.1.5 255.255.255.0
no shut
!
int gi0/1
ip add 57.1.1.5 255.255.255.0
no shut
!
int gi0/2
ip add 59.1.1.5 255.255.255.0
no shut
exit
!
router eigrp 100
net 0.0.0.0 255.255.255.255
end
R9
en
conf t
hostname iosv-9
line console 0
logg syn
privi l 15
exit
!
int gi0/2
ip add 25.1.1.5 255.255.255.0
no shut
!
int gi0/3
ip add 35.1.1.5 255.255.255.0
no shut
!
int gi0/2
ip add 59.1.1.9 255.255.255.0
no shut
exit
!
router eigrp 100
net 0.0.0.0 255.255.255.255
end
!
[Site1]
R2
en
conf t
hostname iosv-2
line console 0
logg syn
privi l 15
exit
!
int gi0/0
ip add 25.1.1.2 255.255.255.0
no shut
!
int gi0/1
ip add 24.1.1.2 255.255.255.0
no shut
!
int tunnel100
ip add 100.1.1.2 255.255.255.0
tunnel mode gre multi
tunnel source 25.1.1.2
ip nhrp network-id 100
ip nhrp nhs 100.1.1.1 nbma 15.1.1.1 multi
ip nhrp nhs 100.1.1.7 nbma 57.1.1.7 multi
ip nhrp redirect
exit
!
router eigrp 100
net 25.1.1.2 0.0.0.0
net 24.1.1.2 0.0.0.0
net 100.1.1.2 0.0.0.0
passive-int gi0/1
end
!
R4
en
conf t
hostname iosv-4
line console 0
logg syn
privi l 15
exit
!
int gi0/0
ip add 24.1.1.4 255.255.255.0
no shut
!
router eigrp 100
net 24.1.1.4 0.0.0.0
end
[Site2]
R3
en
conf t
hostname iosv-3
line console 0
logg syn
privi l 15
exit
!
int gi0/0
ip add 35.1.1.3 255.255.255.0
no shut
!
int gi0/1
ip add 36.1.1.3 255.255.255.0
no shut
!
int tunnel100
ip add 100.1.1.3 255.255.255.0
tunnel mode gre multi
tunnel source 35.1.1.3
ip nhrp network-id 100
ip nhrp nhs 100.1.1.1 nbma 15.1.1.1 multi
ip nhrp nhs 100.1.1.7 nbma 57.1.1.7 multi
ip nhrp redirect
exit
!
router eigrp 100
net 35.1.1.3 0.0.0.0
net 36.1.1.3 0.0.0.0
net 100.1.1.3 0.0.0.0
passive-int gi0/1
end
!
R6
en
conf t
hostname iosv-4
line console 0
logg syn
privi l 15
exit
!
int gi0/0
ip add 36.1.1.6 255.255.255.0
no shut
!
router eigrp 100
net 36.1.1.6 0.0.0.0
end
デフォルトルートで経路制御
1) ロンゲストマッチ
iosv-7#sh run | s GigabitEthernet0/0
interface GigabitEthernet0/0
ip address 187.1.1.7 255.255.255.0
ip summary-address eigrp 100 0.0.0.0 0.0.0.0
iosv-8#sh ip ro | b Gate
Gateway of last resort is 187.1.1.7 to network 0.0.0.0
D* 0.0.0.0/0 [90/3072] via 187.1.1.7, 00:38:49, GigabitEthernet0/0
15.0.0.0/24 is subnetted, 1 subnets
D 15.1.1.0 [90/3072] via 187.1.1.1, 00:05:43, GigabitEthernet0/0
18.0.0.0/32 is subnetted, 1 subnets
C 18.1.1.8 is directly connected, Loopback1
24.0.0.0/24 is subnetted, 1 subnets
D 24.1.1.0 [90/3584] via 187.1.1.1, 00:17:42, GigabitEthernet0/0
25.0.0.0/24 is subnetted, 1 subnets
D 25.1.1.0 [90/3328] via 187.1.1.1, 00:33:26, GigabitEthernet0/0
35.0.0.0/24 is subnetted, 1 subnets
D 35.1.1.0 [90/3328] via 187.1.1.1, 00:33:23, GigabitEthernet0/0
36.0.0.0/24 is subnetted, 1 subnets
D 36.1.1.0 [90/3584] via 187.1.1.1, 00:04:16, GigabitEthernet0/0
57.0.0.0/24 is subnetted, 1 subnets
D 57.1.1.0 [90/3328] via 187.1.1.1, 00:38:49, GigabitEthernet0/0
100.0.0.0/24 is subnetted, 1 subnets
D 100.1.1.0 [90/26880256] via 187.1.1.1, 00:02:17, GigabitEthernet0/0
187.1.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 187.1.1.0/24 is directly connected, GigabitEthernet0/0
L 187.1.1.8/32 is directly connected, GigabitEthernet0/0
<略>
iosv-7のみiosv-8方向のI/Fでip summary-addressを使ってデフォルトルートを広告している。
経路選択はロンゲストマッチが基本なので、特定のアドレスを広告しているiosv-1からのルートがiosv-7よりも優先される。
そのため、デフォルトルートはiosv-7がネクストホップであるものの、それ以外の経路のネクストホップは軒並みiosv-1である。
2) EIGRPネイバー阻止
iosv-1#sh run | s Tunnel100
interface Tunnel100
ip summary-address eigrp 100 0.0.0.0 0.0.0.0
iosv-7#sh run | s Tunnel100
interface Tunnel100
ip summary-address eigrp 100 0.0.0.0 0.0.0.0
iosv-1#sh ip eigrp nei
EIGRP-IPv4 Neighbors for AS(100)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
4 100.1.1.2 Tu100 13 00:05:24 99 1434 0 71
3 100.1.1.3 Tu100 13 00:05:29 75 1434 0 75
2 187.1.1.7 Gi0/0 13 00:43:42 28 168 0 105
1 15.1.1.5 Gi0/1 11 00:44:47 25 150 0 141
0 187.1.1.8 Gi0/0 10 00:45:09 28 168 0 484
iosv-7#sh ip eigrp nei
EIGRP-IPv4 Neighbors for AS(100)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
4 100.1.1.3 Tu100 13 00:07:20 23 1512 0 73
3 100.1.1.2 Tu100 12 00:20:36 41 1470 0 71
2 187.1.1.1 Gi0/0 10 00:43:01 58 348 0 100
0 187.1.1.8 Gi0/0 10 00:43:01 18 108 0 48
1 57.1.1.5 Gi0/1 14 00:44:04 11 100 0 143
summary-addressでトンネルからの広告をデフォルトルートのみにすることでiosv-1,7のトンネルがEIGRPネイバーにならない理屈は理解できるけど、なぜそうする必要があるかわからない。
CiscoPressではSingle hubの時と同様にって言うてるから、さかのぼらないといけない。
お洒落なOffset-list
設定
router eigrp 100
network 57.1.1.7 0.0.0.0
network 100.1.1.7 0.0.0.0
network 187.1.1.7 0.0.0.0
offset-list 0 out 500 Tunnel100
offset-list、ACLの指定なし(0)、メトリックを500加算してトンネルのout方向に当てることで、iosv-1のトンネルを優先させるように制御する。
目から鱗。
Before
iosv-3#sh ip ro | b Gate
Gateway of last resort is 100.1.1.7 to network 0.0.0.0
D* 0.0.0.0/0 [90/26880256] via 100.1.1.7, 00:01:28, Tunnel100
[90/26880256] via 100.1.1.1, 00:01:28, Tunnel100
<略>
After
iosv-2#sh ip ro | b Gate
Gateway of last resort is 100.1.1.1 to network 0.0.0.0
D* 0.0.0.0/0 [90/26880256] via 100.1.1.1, 00:00:09, Tunnel100
<略>
offset-list設定前はiosv-1とiosv-7の2つがネクストホップとして設定されているが、設定後はiosv-1のみとなっている。
failover
iosv-1(config)#int tunnel100
iosv-1(config-if)#shut
iosv-3#sh ip ro | b Gate
Gateway of last resort is 100.1.1.7 to network 0.0.0.0
D* 0.0.0.0/0 [90/26880756] via 100.1.1.7, 00:00:01, Tunnel100
<略>
iosv-3#trace 100.1.1.2
Type escape sequence to abort.
Tracing the route to 100.1.1.2
VRF info: (vrf in name/id, vrf out name/id)
1 100.1.1.7 18 msec
100.1.1.2 16 msec 21 msec
iosv-3#trace 100.1.1.2
Type escape sequence to abort.
Tracing the route to 100.1.1.2
VRF info: (vrf in name/id, vrf out name/id)
1 100.1.1.2 9 msec 17 msec *
iosv-1がお亡くなりになった際は、iosv-7を使っているし、Phase3も問題なく動いている。
passive-int疑問
router eigrp 100
network 24.1.1.2 0.0.0.0
network 25.1.1.2 0.0.0.0
network 100.1.1.2 0.0.0.0
passive-interface
CiscoPressに記載の通りのコンフィグ。
明示的にgi0/1からEIGRPのアップデートを送信する設定を入れておいて、明示的にpassive-intの設定も入れている。そんならそもそもnetwork 24.1.1.2 0.0.0.0すら入れなければよくないか?という疑問
network 24.1.1.2 0.0.0.0を抜いた状態でiosv-2,4間をパケットキャプチャしてみたけど、予想通りEIGRPパケットは1つも取れない。
やっぱり最初から設定入れないほうがよくない?